The USNH Systems Status website provides timely information about scheduled maintenance, unplanned service interruptions, and the status of major IT services across all USNH institutions.

Subscribe to get notified by email when there are updates to service status.

Fiber Break Durham - Manchester Tuesday 10th November 2020 07:15:00


7:15 AM

We are currently seeing our connectivity between Durham and Manchester offline. Services to Boston are currently down. Traffic has been re-routed through other providers at this time and all sites are currently still online.

8:50 AM

Fiber break discovered near Manchester. Currently working with service providers to open a ticket and get a repair crew out.

update on service impact: Currently all IPv6 services to the internet are offline.

We will update with an ETA once we receive one from our providers.

Update :10:50pm

Repair has been completed and services to Boston are back online.

Fiber break was due to squirrel damage just outside Manchester.